DDUC: Resucitando una Nintendo DS Lite

100_6437  Hace ya bastantes meses conseguí una Nintendo DSLite barata, pero en un estado deplorable. El caso es que en un principio funcionaba (o eso decía el vendedor) pero cuando la tuve en mis manos no hacía ni el intento. Curiosamente sí que llegaba a cargar, los leds se encendía y daba señal al enchufarla, así que “muy rota” no debía de estar. Bueno, pues hace unas semanas decidí darle una segunda oportunidad, y para mi sorpresa ya la tengo funcionando. No le hice muchas fotos a la reparación ya que no tenía si quiera esperanza de que llegara a encender, estaba en un estado más que deplorable, pero al menos os cuento mi experiencia.

A decir verdad la consola había tenido muy mala vida, el dueño me contó que había sido de sus hijos, y que literalmente la habían destrozado. Primero tuvo varias caídas “accidentales”, con lo que la carcasa estaba con golpes y rajas por todos lados. Luego tuvo el clásico problema de la “bisagra de la muerte”, se partió la bisagra de la pantalla superior, y ahí fue cuando el dueño decidió jubilarla. El caso es que la consola la guardó “encendiendo”, al menos la pantalla inferior funcionaba, pero después de un tiempo en el desván se conoce que se había suicidado.

Lo primero que hice fue buscar información de estos problemas, os hago un resumen rápido:

  • Si la consola enciende “un segundo” y se apaga: Puede ser problema de la faja de datos de la pantalla superior. Si no está bien conectada o hace mal contacto, la consola hace precisamente ésto (algo normal si se tiene en cuenta que la bisagra estaba rota).
      Solución: Abrir la consola y recolocar la faja de datos, pero no pasó nada. Éste no era el problema, ya que la consola ni siquiera llegaba a parpadear
  • Si la consola no enciende ni un segundo, puede que algún fusible haya petado.
      Solución: Repasar los fusibles de la consola (ver imagen más abajo). Los fusibles estaban perfectamente, ninguno había petado. Además, los leds de carga funcionaban así que tampoco podía ser éste el problema.
  • Si sigue sin encender, revisar baterías, resto del circuito, interruptor, etc…
      Solución: La batería estaba bien, tenía otra nintendo DS para comprobarla y cargaba perfectamente. El circuito tenía algunas zonas donde había sufrido un ataque de óxido, pero lo testé con el multímetro y las líneas estaban bien. Además lo limpié como buenamente pude y salió todo sin mucha dificultad.

Por último revisé el interruptor, y éste sí que hacía cosas raras. Estaba cerca de la zona oxidada, y no parecía funcionar correctamente. Éste es un interruptor tipo “bumper”, es decir que sólo deja pasar corriente al apretar hacia arriba. La consola recibe una señal de encendido un segundo, y luego el interruptor vuelve a su posición “abierto”. Os dejo el pinout del interruptor en cuestión, por si os sirve de utilidad:

Bueno, pues los pines 1 y 2 deberían dar continuidad cuando está apretado el interruptor, y en este caso no pasaba. Al menos encontré uno de los problemas, el interruptor estaba roto y debía de cambiarlo, lo malo es que no tenía ninguno a mano. Aunque en ebay podéis encontrar varias tiendas que lo venden a un precio razonable, decidí desoldarlo y abrirlo a ver qué pasaba (total, es un interruptor muy secillote). El interruptor tiene dos partes: la “cáscara” que está formada por un trozo de plástico y una chapita de metal, y luego el interior que no es más que la palanca de plástico que se mueve, un muelle que la hace volver a su posición, y unas chapitas pequeñas de cobre donde se hace contacto según la posición del interruptor.

100_6429

La chapita de metal se puede quitar fácilmente levantando los extremos, pero hay que tener cuidado de que el muelle que hay dentro no salga disparado. Por suerte el muelle no está metido “a presión”, mientras no se aprieta el interruptor está en una posición casi relajada, así que mientras tengáis cuidado de que no se caiga no pasará nada. Una vez vaciado, se pueden ver las chapitas de cobre que hacen contacto. En mi caso, estaban llenas de óxido y mugre, normal que no funcionara. Con un cutter fino pude limpiarlo bien y volver a cerrar el interruptor… quedó como nuevo.

Después de soldarlo hice una prueba, y “TACHAN!” la consola funcionó “casi” perfectamente. La consola encendía, hacía los clásicos ruiditos, pero las pantallas estaban en blanco. Bueno “casi” en blanco, se veían zonas con “basura” en vez de gráficos, aunque se intuía que estaba haciendo cosas. Hice otra prueba, metí un juego de GBA para ver si el modo compatible funcionaba mejor, y ocurría lo mismo. Se oía perfectamente el juego, pero no se distinguía nada en la pantalla. Sólo se veía un fondo blanco con algunas manchas o líneas negras.

Al principio pensé que los LCDs de la consola habían petado, ya que los golpes que os comenté eran bastante marcados. Estéticamente estaban bien, pero a saber qué tal les habrían sentado las caidas a manos de los hijos del anterior dueño. Saqué la DSL que tenía de repuesto para probarlos, quité sus LCD originales, puse los de la DS muerta… y funcionaban “perfectamente”. Bueno, la pantalla superior no se veía del todo correcta, algunos colores se ven raros, pero la inferior y el táctil iban perfectas.

Volví a mirar la placa base muerta, pensando si el óxido podría haberse comido otro trozo del circuito. La ram de video se encuentra debajo del zócalo de cartuchos, tendría que desmontarlo para verificar que estaba en orden. Andes de desoldar nada volví a repasar la zona que limpié de óxido, se veía normal, todo normal…. un momento…

Comparé la placa rota con la que tenía funcionando, y me encontré que faltaba un condensador. Era uno de  los condensadores enanos, de un tamaño de 2mm, y que estaba donde limpié el óxido. Después de pensar un poco, se conoce que al limpiar esa zona, ese condensador estaba flojo y me lo llevé con el algodón. Lo malo es que no tengo ni idea de qué valor podría tener, éstos condensadores tan pequeños suelen ser de poca capacitancia, entre 1 y 10nf normalmente (depende del tamaño, pero es lo que suelo ver en circuitos de este estilo). No tenía nada tan pequeño a mano, pero puestos a probar (total, ya estaba rota, no creí que fuera a romperse más), lo reemplacé por uno de 100nf, que era lo que tenía a mano.

100_6430

Cerré la consola,puse las pilas y las pantallas volvieron a lucir normalmente. Bueno, lo de “normalmente” es un decir, la pantalla superior sí que está cascada. Los colores se veían raros dependiendo de la posición, podía pasar de un “monocromo” azul a un “monocromo” rojo, aunque a veces también se pueden ver los colores normales (vamos, parecido a cuando lo probé en la DS “buena”). El conector está bien, así que supongo que la faja de datos está rajada en algún punto. Lo miraré en otro momento si tengo tiempo. Igualmente, los botones L y R funcionan fatal, debería de cambiarlos por otros nuevos, pero creo que lo dejaré así hasta que vuelva a tener tiempo. También pude “arreglar” la bisagra rota. Bueno, hice una ñapa con un poco de cola termofusible y un trozo de cartón, pero por lo menos ya no se cae.

Y con esto doy por terminada la ñapa, por ebay hay carcasas bastante majas por 6-8€ para poder adecentar la consola. Ya os contaré si al final cojo alguna, ya que las más baratas son las chinas, y ya nos conocemos…

Perfil del redactor

Nací en el 83, desde entonces he ido descubriendo que los errores se acumulan y los aciertos desaparecen rápidamente. Mi primera consola fué una NES clónica con el galaga, luego pasé a supernintendo, PC y otros sistemas con dos mandos y muchos bits. Informático de profesión, se me conoce como "el que trabaja ordenadores" y "el destructor de consolas".